The file "ext.dll" is not a SharpShell Server.

Jun 5, 2016 at 2:58 AM
Hello,

When I want to test my extension, i got this error. I have followed the instructions on CodeProject, but this error still happens. I have tried to find a solution, but i have no idea why this happens. Please help me...

https://onedrive.live.com/redir?resid=9D1CA168ECEF90B5!5233&authkey=!AHsL5jrJ22ftpNM&v=3&ithint=photo%2cpng

Regards.
Jun 5, 2016 at 3:48 AM
Edited Jun 5, 2016 at 5:18 AM
Hello,

My problem above was resolved :)

Well, i have another problem. When i tried to test my contextmenu handlers, it works perfectly. But when i tried to register my icon handler, i got an error from server manager that "Cannot open default key for class .myextension".

My Icon handler's attribute:
[ComVisible(true)]
[COMServerAssociation(AssociationType.FileExtension, ".myextension")]

Did i make any mistakes?

Regards.
Jun 5, 2016 at 10:56 PM
Well, I've find a solution to my problem above.

To fix the error, just open the regedit, goto HKCU -> .myextension, then create a new key called DefaultIcon inside it.

Hope this help the others...